]> git.proxmox.com Git - ceph.git/blobdiff - ceph/debian/rules
update sources to v12.1.3
[ceph.git] / ceph / debian / rules
index f8fb8117d7456b978b4f6f4e6ff82e1b1209bf91..92bc0b5877660b60adfd5aac156d35af382b6a0f 100755 (executable)
@@ -22,6 +22,13 @@ ifeq ($(DEB_HOST_ARCH), armel)
   extraopts += -DWITH_ATOMIC_OPS=OFF
 endif
 
+ifneq (,$(filter $(DEB_HOST_ARCH), arm armel armhf arm64 i386 amd64 mips mipsel powerpc ppc64))
+  # beast depends on libboost_context which only support the archs above
+  extraopts += -DWITH_RADOSGW_BEAST_FRONTEND=ON
+else
+  extraopts += -DWITH_RADOSGW_BEAST_FRONTEND=OFF
+endif
+
 %:
        dh $@ --buildsystem=cmake --with javahelper,python2,python3,systemd --parallel
 
@@ -52,8 +59,8 @@ override_dh_installdocs:
        dh_installdocs -a --all ChangeLog
 
 override_dh_installlogrotate:
-       cp src/logrotate.conf debian/ceph-base.ceph.logrotate
-       dh_installlogrotate -pceph-base --name=ceph
+       cp src/logrotate.conf debian/ceph-common.logrotate
+       dh_installlogrotate -pceph-common
 
 override_dh_installinit:
        # dh_installinit is only set up to handle one upstart script
@@ -89,10 +96,12 @@ override_dh_installinit:
        install -m0644 systemd/ceph-mon@.service debian/ceph-mon/lib/systemd/system
        install -m0644 systemd/ceph-osd@.service debian/ceph-osd/lib/systemd/system
        install -m0644 systemd/ceph-disk@.service debian/ceph-osd/lib/systemd/system
+       install -m0644 systemd/ceph-volume@.service debian/ceph-osd/lib/systemd/system
        install -m0644 systemd/rbdmap.service debian/ceph-common/lib/systemd/system
        sed -i s./etc/sysconfig/./etc/default/.g debian/ceph-mon/lib/systemd/system/ceph-mon@.service
        sed -i s./etc/sysconfig/./etc/default/.g debian/ceph-osd/lib/systemd/system/ceph-osd@.service
        sed -i s./etc/sysconfig/./etc/default/.g debian/ceph-osd/lib/systemd/system/ceph-disk@.service
+       sed -i s./etc/sysconfig/./etc/default/.g debian/ceph-osd/lib/systemd/system/ceph-volume@.service
        install -m0644 systemd/ceph-mon.target debian/ceph-mon/lib/systemd/system
        install -m0644 systemd/ceph-osd.target debian/ceph-osd/lib/systemd/system
 
@@ -124,9 +133,16 @@ override_dh_installinit:
        dh_installinit -p ceph-base --name ceph --no-start
        dh_installinit -p radosgw --no-start
 
-override_dh_systemd_start:
+       # NOTE: execute systemd helpers so they pickup dh_install'ed units and targets
+       dh_systemd_enable
        dh_systemd_start --no-restart-on-upgrade
 
+override_dh_systemd_enable:
+       # systemd enable done as part of dh_installinit
+
+override_dh_systemd_start:
+       # systemd start done as part of dh_installinit
+
 override_dh_strip:
        dh_strip -pceph-mds --dbg-package=ceph-mds-dbg
        dh_strip -pceph-fuse --dbg-package=ceph-fuse-dbg