]> git.proxmox.com Git - ceph.git/blobdiff - ceph/debian/rules
update sources to v12.1.0
[ceph.git] / ceph / debian / rules
index f8fb8117d7456b978b4f6f4e6ff82e1b1209bf91..d4b3c97f719c3f20121ceedd808bbb17a18a6aef 100755 (executable)
@@ -22,6 +22,13 @@ ifeq ($(DEB_HOST_ARCH), armel)
   extraopts += -DWITH_ATOMIC_OPS=OFF
 endif
 
+ifneq (,$(filter $(DEB_HOST_ARCH), arm armel armhf arm64 i386 amd64 mips mipsel powerpc ppc64))
+  # beast depends on libboost_context which only support the archs above
+  extraopts += -DWITH_RADOSGW_BEAST_FRONTEND=ON
+else
+  extraopts += -DWITH_RADOSGW_BEAST_FRONTEND=OFF
+endif
+
 %:
        dh $@ --buildsystem=cmake --with javahelper,python2,python3,systemd --parallel
 
@@ -52,8 +59,8 @@ override_dh_installdocs:
        dh_installdocs -a --all ChangeLog
 
 override_dh_installlogrotate:
-       cp src/logrotate.conf debian/ceph-base.ceph.logrotate
-       dh_installlogrotate -pceph-base --name=ceph
+       cp src/logrotate.conf debian/ceph-common.logrotate
+       dh_installlogrotate -pceph-common
 
 override_dh_installinit:
        # dh_installinit is only set up to handle one upstart script