]> git.proxmox.com Git - ceph.git/blobdiff - ceph/doc/man/8/CMakeLists.txt
update sources to v12.1.3
[ceph.git] / ceph / doc / man / 8 / CMakeLists.txt
index 76bab3a9b35603cdf3f53b684487b44425d476ec..8a2204c713730204df510f18bb27a78d1bef9ef3 100644 (file)
@@ -54,12 +54,17 @@ if(WITH_RBD)
   list(APPEND man_srcs
        ceph-rbdnamer.rst
        rbd-mirror.rst
-       rbd-nbd.rst
        rbd-replay-many.rst
        rbd-replay-prep.rst
        rbd-replay.rst
        rbdmap.rst
        rbd.rst)
+  if(LINUX)
+    list(APPEND man_srcs rbd-nbd.rst)
+  endif()
+  if(FREEBSD)
+    list(APPEND man_srcs rbd-ggate.rst)
+  endif()
 endif()
 
 foreach(man ${man_srcs})