]> git.proxmox.com Git - ceph.git/blobdiff - ceph/src/boost/libs/core/test/CMakeLists.txt
update ceph source to reef 18.1.2
[ceph.git] / ceph / src / boost / libs / core / test / CMakeLists.txt
index 82f1b33bc5ea8baed45457b4c258400b3edb3b9c..7524ae6e416c604c8e17abcec0be04ed88925a08 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 2018, 2019 Peter Dimov
+# Copyright 2018-2021 Peter Dimov
 # Distributed under the Boost Software License, Version 1.0.
 # See accompanying file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt
 
@@ -6,7 +6,26 @@ include(BoostTestJamfile OPTIONAL RESULT_VARIABLE HAVE_BOOST_TEST)
 
 if(HAVE_BOOST_TEST)
 
-boost_test_jamfile(FILE Jamfile.v2 LINK_LIBRARIES Boost::core Boost::static_assert Boost::type_traits Boost::throw_exception)
+boost_test_jamfile(FILE Jamfile.v2 LINK_LIBRARIES Boost::core Boost::static_assert)
+
+set(BOOST_TEST_LINK_LIBRARIES Boost::core Boost::type_traits)
+
+boost_test(TYPE run SOURCES eif_constructors.cpp)
+boost_test(TYPE run SOURCES eif_dummy_arg_disambiguation.cpp)
+boost_test(TYPE run SOURCES eif_lazy.cpp)
+boost_test(TYPE run SOURCES eif_lazy_test.cpp)
+boost_test(TYPE run SOURCES eif_member_templates.cpp)
+boost_test(TYPE run SOURCES eif_namespace_disambiguation.cpp)
+boost_test(TYPE run SOURCES eif_no_disambiguation.cpp)
+boost_test(TYPE run SOURCES eif_partial_specializations.cpp)
+
+set(BOOST_TEST_LINK_LIBRARIES Boost::core Boost::throw_exception)
+
+boost_test(TYPE run SOURCES no_exceptions_support_test.cpp)
+
+set(BOOST_TEST_LINK_LIBRARIES Boost::core Boost::utility)
+
+boost_test(TYPE run SOURCES sv_conversion_test2.cpp)
 
 endif()