]> git.proxmox.com Git - ceph.git/blobdiff - ceph/src/boost/libs/intrusive/CMakeLists.txt
update ceph source to reef 18.1.2
[ceph.git] / ceph / src / boost / libs / intrusive / CMakeLists.txt
index 3ab541fd4a079f56c1d7753138f35b4930ca160c..15f4a41274e0fd15a8f179064161c248e0c0064a 100644 (file)
@@ -1,15 +1,12 @@
 # Copyright 2019 Mike Dev
 # Distributed under the Boost Software License, Version 1.0.
 # See accompanying file LICENSE_1_0.txt or copy at https://www.boost.org/LICENSE_1_0.txt
-#
-# NOTE: CMake support for Boost.Intrusive is currently experimental at best
-#       and the interface is likely to change in the future
 
-cmake_minimum_required( VERSION 3.5 )
+cmake_minimum_required( VERSION 3.5...3.20 )
 
-project( Boost.Intrusive LANGUAGES CXX )
+project( boost_intrusive VERSION "${BOOST_SUPERPROJECT_VERSION}" LANGUAGES CXX )
 
-add_library (boost_intrusive INTERFACE )
+add_libraryboost_intrusive INTERFACE )
 add_library( Boost::intrusive ALIAS boost_intrusive )
 
 target_include_directories( boost_intrusive INTERFACE include )