]> git.proxmox.com Git - ceph.git/blobdiff - ceph/src/boost/libs/lambda/test/cmake_subdir_test/CMakeLists.txt
update ceph source to reef 18.1.2
[ceph.git] / ceph / src / boost / libs / lambda / test / cmake_subdir_test / CMakeLists.txt
diff --git a/ceph/src/boost/libs/lambda/test/cmake_subdir_test/CMakeLists.txt b/ceph/src/boost/libs/lambda/test/cmake_subdir_test/CMakeLists.txt
new file mode 100644 (file)
index 0000000..b6b06a8
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 2018, 2019, 2021 Peter Dimov
+# Distributed under the Boost Software License, Version 1.0.
+# See accompanying file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt
+
+cmake_minimum_required(VERSION 3.5...3.16)
+
+project(cmake_subdir_test LANGUAGES CXX)
+
+set(BOOST_INCLUDE_LIBRARIES lambda)
+
+add_subdirectory(../../../../ deps/boost)
+
+# --target check
+
+add_executable(quick ../quick.cpp)
+target_link_libraries(quick Boost::lambda Boost::core)
+
+enable_testing()
+add_test(quick quick)
+
+add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND} --output-on-failure -C $<CONFIG>)