]> git.proxmox.com Git - ceph.git/blobdiff - ceph/src/boost/libs/scope_exit/CMakeLists.txt
update ceph source to reef 18.1.2
[ceph.git] / ceph / src / boost / libs / scope_exit / CMakeLists.txt
diff --git a/ceph/src/boost/libs/scope_exit/CMakeLists.txt b/ceph/src/boost/libs/scope_exit/CMakeLists.txt
new file mode 100644 (file)
index 0000000..0b9500e
--- /dev/null
@@ -0,0 +1,29 @@
+# Generated by `boostdep --cmake scope_exit`
+# Copyright 2020 Peter Dimov
+# Distributed under the Boost Software License, Version 1.0.
+# https://www.boost.org/LICENSE_1_0.txt
+
+cmake_minimum_required(VERSION 3.5...3.16)
+
+project(boost_scope_exit VERSION "${BOOST_SUPERPROJECT_VERSION}" LANGUAGES CXX)
+
+add_library(boost_scope_exit INTERFACE)
+add_library(Boost::scope_exit ALIAS boost_scope_exit)
+
+target_include_directories(boost_scope_exit INTERFACE include)
+
+target_link_libraries(boost_scope_exit
+  INTERFACE
+    Boost::config
+    Boost::function
+    Boost::preprocessor
+    Boost::type_traits
+    Boost::typeof
+)
+
+if(BUILD_TESTING AND EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/test/CMakeLists.txt")
+
+  add_subdirectory(test)
+
+endif()
+