]> git.proxmox.com Git - ceph.git/blobdiff - ceph/src/boost/libs/system/CMakeLists.txt
update source to Ceph Pacific 16.2.2
[ceph.git] / ceph / src / boost / libs / system / CMakeLists.txt
index 5190213cef9ac89efed227890ad4cec45d872b20..bd1df5d9f06b7c430b8b6b9f5c2b8ba814568655 100644 (file)
@@ -1,12 +1,10 @@
-# Copyright 2018 Mike Dev
+# Copyright 2018-2020 Peter Dimov
 # Distributed under the Boost Software License, Version 1.0.
 # See accompanying file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt
 
-# Partial (add_subdirectory only) and experimental CMake support
-# Subject to change; please do not rely on the contents of this file yet
+cmake_minimum_required(VERSION 3.5...3.16)
 
-cmake_minimum_required(VERSION 3.5)
-project(BoostSystem LANGUAGES CXX)
+project(boost_system VERSION "${BOOST_SUPERPROJECT_VERSION}" LANGUAGES CXX)
 
 add_library(boost_system INTERFACE)
 add_library(Boost::system ALIAS boost_system)
@@ -14,7 +12,13 @@ add_library(Boost::system ALIAS boost_system)
 target_include_directories(boost_system INTERFACE include)
 
 target_link_libraries(boost_system
-    INTERFACE
-        Boost::config
-        Boost::winapi
+  INTERFACE
+    Boost::config
+    Boost::winapi
 )
+
+if(BUILD_TESTING)
+
+  add_subdirectory(test)
+
+endif()