]> git.proxmox.com Git - ceph.git/blobdiff - ceph/src/compressor/zstd/CMakeLists.txt
update sources to 12.2.8
[ceph.git] / ceph / src / compressor / zstd / CMakeLists.txt
index d9d2b6e560d3f7de863a21e8222f05dd7b076f1b..448d610cd0a2f2a393bf2ab1948ec88a991423fb 100644 (file)
@@ -37,8 +37,3 @@ add_dependencies(ceph_zstd ${CMAKE_SOURCE_DIR}/src/ceph_ver.h)
 target_link_libraries(ceph_zstd zstd)
 set_target_properties(ceph_zstd PROPERTIES VERSION 2.0.0 SOVERSION 2)
 install(TARGETS ceph_zstd DESTINATION ${compressor_plugin_dir})
-
-if(WITH_EMBEDDED)
-  add_library(cephd_compressor_zstd STATIC ${zstd_sources})
-  set_target_properties(cephd_compressor_zstd PROPERTIES COMPILE_DEFINITIONS BUILDING_FOR_EMBEDDED)
-endif()