]> git.proxmox.com Git - ceph.git/blobdiff - ceph/src/crimson/os/seastore/CMakeLists.txt
update ceph source to reef 18.2.1
[ceph.git] / ceph / src / crimson / os / seastore / CMakeLists.txt
index 5b1c6187ca2a2061343cc41e4ef83ec0a68e409b..4bdbab8c4e5de8d997cc2fd2c9f11b793126b15a 100644 (file)
@@ -51,6 +51,7 @@ set(crimson_seastore_srcs
   journal.cc
   device.cc
   segment_manager_group.cc
+  record_scanner.cc
   journal/circular_bounded_journal.cc
   ../../../test/crimson/seastore/test_block.cc
   ${PROJECT_SOURCE_DIR}/src/os/Transaction.cc
@@ -61,7 +62,7 @@ CMAKE_DEPENDENT_OPTION(WITH_ZNS "enable Linux ZNS support" OFF
 if(WITH_ZNS)
   find_package(LinuxZNS REQUIRED)
   list(APPEND crimson_seastore_srcs
-    segment_manager/zns.cc)
+    segment_manager/zbd.cc)
 endif()
 
 add_library(crimson-seastore STATIC