]> git.proxmox.com Git - ceph.git/blobdiff - ceph/src/erasure-code/jerasure/CMakeLists.txt
update sources to 12.2.8
[ceph.git] / ceph / src / erasure-code / jerasure / CMakeLists.txt
index 7f752806cda7fa172ba10ea1b1190969e95327d6..cf2c6e0fbf7ac6c558717c5889899d9426f82382 100644 (file)
@@ -102,11 +102,3 @@ foreach(flavor ${jerasure_legacy_flavors})
   install(TARGETS ${plugin_name} DESTINATION ${erasure_plugin_dir})
   add_dependencies(ec_jerasure ${plugin_name})
 endforeach()
-
-if(WITH_EMBEDDED)
-  add_library(cephd_ec_jerasure STATIC
-    $<TARGET_OBJECTS:gf-complete_objs>
-    $<TARGET_OBJECTS:jerasure_objs>
-    ${jerasure_utils_src})
-  set_target_properties(cephd_ec_jerasure PROPERTIES COMPILE_DEFINITIONS BUILDING_FOR_EMBEDDED)
-endif()