]> git.proxmox.com Git - ceph.git/blobdiff - ceph/src/erasure-code/shec/CMakeLists.txt
update sources to 12.2.8
[ceph.git] / ceph / src / erasure-code / shec / CMakeLists.txt
index d5f8e15ada4a694b46827d6fd7920edd1803f5c8..1793b127ecd51a812a7d3fac3641dac0a635e376 100644 (file)
@@ -33,9 +33,3 @@ foreach(flavor ${jerasure_legacy_flavors})
   install(TARGETS ${plugin_name} DESTINATION ${erasure_plugin_dir})
   add_dependencies(ec_shec ${plugin_name})
 endforeach()
-
-if(WITH_EMBEDDED)
-  # note we rely on the fact this will always be statically linked with jerasure
-  add_library(cephd_ec_shec STATIC ${shec_utils_srcs})
-  set_target_properties(cephd_ec_shec PROPERTIES COMPILE_DEFINITIONS BUILDING_FOR_EMBEDDED)
-endif()