]> git.proxmox.com Git - ceph.git/blobdiff - ceph/src/isa-l/crc/Makefile.am
update sources to v12.1.1
[ceph.git] / ceph / src / isa-l / crc / Makefile.am
index d1fb3207551fc428904c2fa6707642da58e7e8fb..74b964743b5244156c52ed2794d381d9353ca628 100644 (file)
@@ -1,5 +1,5 @@
 ########################################################################
-#  Copyright(c) 2011-2015 Intel Corporation All rights reserved.
+#  Copyright(c) 2011-2017 Intel Corporation All rights reserved.
 #
 #  Redistribution and use in source and binary forms, with or without
 #  modification, are permitted provided that the following conditions
 ########################################################################
 
 lsrc  += \
+       crc/crc_base.c \
+       crc/crc64_base.c
+
+lsrc_base_aliases += crc/crc_base_aliases.c
+lsrc_x86_32       += crc/crc_base_aliases.c
+
+lsrc_x86_64 += \
        crc/crc16_t10dif_01.asm \
        crc/crc16_t10dif_by4.asm \
        crc/crc32_ieee_01.asm \
@@ -35,14 +42,23 @@ lsrc  += \
        crc/crc32_iscsi_01.asm \
        crc/crc32_iscsi_00.asm \
        crc/crc_multibinary.asm \
-       crc/crc_base.c
+       crc/crc64_multibinary.asm \
+       crc/crc64_ecma_refl_by8.asm \
+       crc/crc64_ecma_norm_by8.asm \
+       crc/crc64_iso_refl_by8.asm \
+       crc/crc64_iso_norm_by8.asm \
+       crc/crc64_jones_refl_by8.asm \
+       crc/crc64_jones_norm_by8.asm
 
-extern_hdrs +=  include/crc.h
+src_include += -I $(srcdir)/crc
+extern_hdrs +=  include/crc.h include/crc64.h
 
 other_src   +=  include/reg_sizes.asm include/types.h include/test.h
 
-check_tests +=  crc/crc16_t10dif_test crc/crc32_ieee_test crc/crc32_iscsi_test
+check_tests +=  crc/crc16_t10dif_test crc/crc32_ieee_test crc/crc32_iscsi_test \
+               crc/crc64_funcs_test
 
-perf_tests  +=  crc/crc16_t10dif_perf crc/crc32_ieee_perf crc/crc32_iscsi_perf
+perf_tests  +=  crc/crc16_t10dif_perf crc/crc32_ieee_perf crc/crc32_iscsi_perf \
+               crc/crc64_funcs_perf
 
-examples    +=  crc/crc_simple_test
+examples    +=  crc/crc_simple_test crc/crc64_example