]> git.proxmox.com Git - ceph.git/blobdiff - ceph/src/jaegertracing/opentelemetry-cpp/tools/vcpkg/ports/hidapi/hidapi-config.cmake
update ceph source to reef 18.1.2
[ceph.git] / ceph / src / jaegertracing / opentelemetry-cpp / tools / vcpkg / ports / hidapi / hidapi-config.cmake
diff --git a/ceph/src/jaegertracing/opentelemetry-cpp/tools/vcpkg/ports/hidapi/hidapi-config.cmake b/ceph/src/jaegertracing/opentelemetry-cpp/tools/vcpkg/ports/hidapi/hidapi-config.cmake
new file mode 100644 (file)
index 0000000..126685a
--- /dev/null
@@ -0,0 +1,48 @@
+# - try to find HIDAPI library\r
+# from http://www.signal11.us/oss/hidapi/\r
+#\r
+# Cache Variables: (probably not for direct use in your scripts)\r
+#  HIDAPI_INCLUDE_DIR\r
+#  HIDAPI_LIBRARY\r
+#\r
+# Non-cache variables you might use in your CMakeLists.txt:\r
+#  HIDAPI_FOUND\r
+#  HIDAPI_INCLUDE_DIRS\r
+#  HIDAPI_LIBRARIES\r
+#\r
+# Requires these CMake modules:\r
+#  FindPackageHandleStandardArgs (known included with CMake >=2.6.2)\r
+#\r
+# Original Author:\r
+# 2009-2010 Ryan Pavlik <rpavlik@iastate.edu> <abiryan@ryand.net>\r
+# http://academic.cleardefinition.com\r
+# Iowa State University HCI Graduate Program/VRAC\r
+#\r
+# Copyright Iowa State University 2009-2010.\r
+# Distributed under the Boost Software License, Version 1.0.\r
+# (See accompanying file LICENSE_1_0.txt or copy at\r
+# http://www.boost.org/LICENSE_1_0.txt)\r
+\r
+# hacking FindHIDAPI.cmake as hidapi-config.cmake\r
+\r
+find_library(HIDAPI_LIBRARY\r
+       NAMES hidapi hidapi-libusb)\r
+\r
+find_path(HIDAPI_INCLUDE_DIR\r
+       NAMES hidapi.h\r
+       PATH_SUFFIXES\r
+       hidapi)\r
+\r
+include(FindPackageHandleStandardArgs)\r
+find_package_handle_standard_args(HIDAPI\r
+       DEFAULT_MSG\r
+       HIDAPI_LIBRARY\r
+       HIDAPI_INCLUDE_DIR)\r
+\r
+if(HIDAPI_FOUND)\r
+       set(HIDAPI_LIBRARIES "${HIDAPI_LIBRARY}")\r
+\r
+       set(HIDAPI_INCLUDE_DIRS "${HIDAPI_INCLUDE_DIR}")\r
+endif()\r
+\r
+mark_as_advanced(HIDAPI_INCLUDE_DIR HIDAPI_LIBRARY)\r