]> git.proxmox.com Git - ceph.git/blobdiff - ceph/src/jaegertracing/thrift/tutorial/rb/Makefile.am
update source to Ceph Pacific 16.2.2
[ceph.git] / ceph / src / jaegertracing / thrift / tutorial / rb / Makefile.am
diff --git a/ceph/src/jaegertracing/thrift/tutorial/rb/Makefile.am b/ceph/src/jaegertracing/thrift/tutorial/rb/Makefile.am
new file mode 100755 (executable)
index 0000000..885cd92
--- /dev/null
@@ -0,0 +1,36 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+#   http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+gen-rb/calculator.rb gen-rb/shared_service.rb: $(top_srcdir)/tutorial/tutorial.thrift
+       $(THRIFT) --gen rb -r $<
+
+all-local: gen-rb/calculator.rb
+
+tutorialserver: all
+       ${RUBY} RubyServer.rb
+
+tutorialclient: all
+       ${RUBY} RubyClient.rb
+
+clean-local:
+       $(RM) -r gen-*
+
+EXTRA_DIST = \
+       RubyServer.rb \
+       RubyClient.rb