]> git.proxmox.com Git - ceph.git/blobdiff - ceph/src/neorados/CMakeLists.txt
import quincy beta 17.1.0
[ceph.git] / ceph / src / neorados / CMakeLists.txt
index 8695b48f0f924fb757a2dc34326a69591eeb05a1..3c7aee7c6fea02a00d2246822cad554adc27e590 100644 (file)
@@ -1,9 +1,11 @@
 add_library(neorados_objs OBJECT
   RADOSImpl.cc)
-compile_with_fmt(neorados_objs)
+target_compile_definitions(neorados_objs PRIVATE
+  $<TARGET_PROPERTY:fmt::fmt,INTERFACE_COMPILE_DEFINITIONS>)
 add_library(neorados_api_obj OBJECT
   RADOS.cc)
-compile_with_fmt(neorados_api_obj)
+target_compile_definitions(neorados_api_obj PRIVATE
+  $<TARGET_PROPERTY:fmt::fmt,INTERFACE_COMPILE_DEFINITIONS>)
 
 add_library(libneorados STATIC
   $<TARGET_OBJECTS:neorados_api_obj>