]> git.proxmox.com Git - ceph.git/blobdiff - ceph/src/rbd_replay/CMakeLists.txt
update sources to v12.1.1
[ceph.git] / ceph / src / rbd_replay / CMakeLists.txt
index a842960a62f2b8f2d2906138f201409d215cb943..2e2e176d80b389fb32eb21cfbbc87c465c1a1af4 100644 (file)
@@ -23,7 +23,7 @@ set(librbd_replay_ios_srcs
 add_library(rbd_replay_ios STATIC ${librbd_replay_ios_srcs})
 target_link_libraries(rbd_replay_ios librbd librados global)
 
-if(${WITH_BABELTRACE})
+if(HAVE_BABELTRACE)
   add_executable(rbd-replay-prep
     rbd-replay-prep.cc)
   target_link_libraries(rbd-replay-prep
@@ -36,7 +36,8 @@ if(${WITH_BABELTRACE})
     global
     babeltrace
     babeltrace-ctf
-    ${Boost_DATE_TIME_LIBRARY}
+    Boost::date_time
     )
   install(TARGETS rbd-replay-prep DESTINATION bin)
-endif(${WITH_BABELTRACE})
+endif(HAVE_BABELTRACE)
+