]> git.proxmox.com Git - ceph.git/blobdiff - ceph/src/spdk/dpdk/drivers/net/pcap/meson.build
update source to Ceph Pacific 16.2.2
[ceph.git] / ceph / src / spdk / dpdk / drivers / net / pcap / meson.build
index 2c2fd11e4417ab7f9c4480adcef518718ae3cf8f..b680710aa03eb7c0bdc2411147b482df4b52caed 100644 (file)
@@ -1,20 +1,9 @@
 # SPDX-License-Identifier: BSD-3-Clause
 # Copyright(c) 2017 Intel Corporation
 
-pcap_dep = dependency('pcap', required: false)
-if pcap_dep.found()
-       build = true
-else
-       # pcap got a pkg-config file only in 1.9.0 and before that meson uses
-       # an internal pcap-config finder, which is not compatible with
-       # cross-compilation, so try to fallback to find_library
-       pcap_dep = cc.find_library('pcap', required: false)
-       if pcap_dep.found() and cc.has_header('pcap.h', dependencies: pcap_dep)
-               build = true
-               pkgconfig_extra_libs += '-lpcap'
-       else
-               build = false
-       endif
+if not dpdk_conf.has('RTE_PORT_PCAP')
+       build = false
+       reason = 'missing dependency, "libpcap"'
 endif
 sources = files('rte_eth_pcap.c')
 ext_deps += pcap_dep