]> git.proxmox.com Git - ceph.git/blobdiff - ceph/src/spdk/dpdk/examples/vhost_scsi/meson.build
update source to Ceph Pacific 16.2.2
[ceph.git] / ceph / src / spdk / dpdk / examples / vhost_scsi / meson.build
diff --git a/ceph/src/spdk/dpdk/examples/vhost_scsi/meson.build b/ceph/src/spdk/dpdk/examples/vhost_scsi/meson.build
deleted file mode 100644 (file)
index 2972e4d..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-# SPDX-License-Identifier: BSD-3-Clause
-# Copyright(c) 2017 Intel Corporation
-
-# meson file, for building this example as part of a main DPDK build.
-#
-# To build this example as a standalone application with an already-installed
-# DPDK instance, use 'make'
-
-if not is_linux
-       build = false
-endif
-
-if not cc.has_header('linux/virtio_scsi.h')
-       build = false
-endif
-
-deps += 'vhost'
-cflags += ['-D_FILE_OFFSET_BITS=64']
-sources = files(
-       'scsi.c', 'vhost_scsi.c'
-)