]> git.proxmox.com Git - ceph.git/blobdiff - ceph/src/test/librbd/CMakeLists.txt
update sources to v12.1.0
[ceph.git] / ceph / src / test / librbd / CMakeLists.txt
index 24cf0b152ae941d39f1d9272e89e16fbb862b7ba..38765811de9ee2a05c89eaa01e4cfec7338e89ef 100644 (file)
@@ -114,12 +114,11 @@ add_executable(ceph_test_librbd_api
   test_support.cc
   test_librbd.cc
   test_main.cc
+  $<TARGET_OBJECTS:libradostest_obj>
   $<TARGET_OBJECTS:common_texttable_obj>)
 target_link_libraries(ceph_test_librbd_api
   librbd
   librados
-  ceph-common
-  radostest
   ${UNITTEST_LIBS})
 set_target_properties(ceph_test_librbd_api PROPERTIES COMPILE_FLAGS
   ${UNITTEST_CXX_FLAGS})