]> git.proxmox.com Git - corosync-pve.git/blobdiff - debian/rules
add patches ensuring smooth upgrades from PVE 4.x
[corosync-pve.git] / debian / rules
index e89d5c035dc5e02328a1254668b9e44599ea14ee..4c37c6002046612d6086f9538a424c8ce134b30d 100755 (executable)
@@ -9,97 +9,23 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-ifneq "$(wildcard /usr/share/quilt/quilt.make)" ""
-include /usr/share/quilt/quilt.make
-endif
-
-config.status: configure
-       dh_testdir
-       # Add here commands to configure the package.
-ifneq "$(wildcard /usr/share/misc/config.sub)" ""
-       cp -f /usr/share/misc/config.sub config.sub
-endif
-ifneq "$(wildcard /usr/share/misc/config.guess)" ""
-       cp -f /usr/share/misc/config.guess config.guess
-endif
-
-       ./configure --prefix=/usr --sysconfdir=/etc --mandir=\$${prefix}/share/man --localstatedir=/var --infodir=\$${prefix}/share/info --with-lcrso-dir=\$${prefix}/lib/lcrso
-
-       touch config.status
-
-build: patch build-stamp
-build-stamp:  config.status 
-       dh_testdir
-
-       # Add here commands to compile the package.
-       $(MAKE)
-
-       touch $@
-
-clean: unpatch
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp 
-
-       # Add here commands to clean up after the build process.
-       [ ! -f Makefile ] || $(MAKE) distclean
-       rm -f config.sub config.guess
-
-       dh_clean 
-
-install: install-stamp
-install-stamp: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k 
-       dh_installdirs
-
-       # Add here commands to install the package into debian/tmp
-       $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install    
-
-       # we do not use corosync-keygen
-       rm $(CURDIR)/debian/tmp/usr/sbin/corosync-keygen
-
-       chmod 0644 $(CURDIR)/debian/tmp/usr/lib/lcrso/*.lcrso
-       strip -s $(CURDIR)/debian/tmp/usr/lib/lcrso/*.lcrso
-
-       touch $@
-
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs 
-       dh_installdocs
-       dh_installexamples
-       dh_install
-#      dh_installmenu
-#      dh_installdebconf       
-       dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-       dh_installinit
-#      dh_installcron
-#      dh_installinfo
-       dh_installman
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-#      dh_perl
-#      dh_python
-       dh_makeshlibs
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install 
+# enable hardening
+export DEB_BUILD_HARDENING=1
+
+%:
+       dh $@ --with=quilt,systemd
+
+override_dh_auto_configure:
+       ./configure --prefix=/usr               \
+       --sysconfdir=/etc                       \
+       --mandir=\$${prefix}/share/man          \
+       --localstatedir=/var                    \
+       --infodir=\$${prefix}/share/info        \
+       --enable-augeas                         \
+       --enable-systemd
+
+override_dh_systemd_enable:
+       dh_systemd_enable -pcorosync-pve --name corosync
+
+#override_dh_systemd_start:
+#      dh_systemd_start -pcorosync-pve --name corosync --no-start