]> git.proxmox.com Git - libxdgmime-perl.git/blobdiff - xdgmime-source/meson.build
Merge commit '73d5a30a1d93eb79761f2472c685afb8e42a8646' from upstream
[libxdgmime-perl.git] / xdgmime-source / meson.build
diff --git a/xdgmime-source/meson.build b/xdgmime-source/meson.build
new file mode 100644 (file)
index 0000000..2b16fda
--- /dev/null
@@ -0,0 +1,17 @@
+project('xdgmime', 'c',
+    version: '0.0',
+    default_options: ['c_std=c99', 'warning_level=1', 'debug=true'],
+    meson_version: '>=0.48.0',
+)
+
+add_project_arguments(
+    '-D_POSIX_C_SOURCE=200809L',
+    '-DXDG_PREFIX=xdg_test',
+    '-DHAVE_MMAP',
+    '-Wmissing-prototypes',
+    '-Wno-sign-compare',
+    language: 'c',
+    native: true,
+)
+
+subdir('src')