]> git.proxmox.com Git - libxdgmime-perl.git/blobdiff - xdgmime-source/src/meson.build
Merge commit '73d5a30a1d93eb79761f2472c685afb8e42a8646' from upstream
[libxdgmime-perl.git] / xdgmime-source / src / meson.build
diff --git a/xdgmime-source/src/meson.build b/xdgmime-source/src/meson.build
new file mode 100644 (file)
index 0000000..ceb407c
--- /dev/null
@@ -0,0 +1,35 @@
+libcommon = static_library('common',
+    'xdgmime.c',
+    'xdgmimeglob.c',
+    'xdgmimeint.c',
+    'xdgmimemagic.c',
+    'xdgmimealias.c',
+    'xdgmimeparent.c',
+    'xdgmimecache.c',
+    'xdgmimeicon.c',
+    native: true,
+)
+
+test_mime = executable('test-mime',
+    'test-mime.c',
+    link_with: libcommon,
+    native: true,
+    install: false,
+)
+meson.override_find_program('test-mime', test_mime)
+
+test_mime_data = executable('test-mime-data',
+    'test-mime-data.c',
+    link_with: libcommon,
+    native: true,
+    install: false,
+)
+meson.override_find_program('test-mime-data', test_mime_data)
+
+print_mime_data = executable('print-mime-data',
+    'print-mime-data.c',
+    link_with: libcommon,
+    native: true,
+    install: false,
+)
+meson.override_find_program('print-mime-data', print_mime_data)