]> git.proxmox.com Git - lxcfs.git/blobdiff - debian/rules
build with fuse 3 for bookworm
[lxcfs.git] / debian / rules
index 12747736a7c6ab85a31f8fbe79a9c68445f81edc..5b5bf7bf7d3e2a1dcb3136228ec94f2421023420 100755 (executable)
@@ -4,16 +4,22 @@
 #export DH_VERBOSE=1
 
 %:
-       dh $@  --with autotools_dev,autoreconf,systemd,quilt
+       dh $@
 
-override_dh_install:
-       find $(CURDIR)/debian/lxcfs/lib/ -type d -empty -delete
+override_dh_auto_clean:
+       rm -fr build
+
+override_dh_auto_configure:
+       mkdir -p build
+       cd build && meson .. --prefix=/usr \
+               -Dinit-script=systemd \
+               -Dfuse-version=3
 
 override_dh_auto_install:
        dh_auto_install --destdir=debian/lxcfs
 
-override_dh_installinit:
-       dh_installinit -p lxcfs --no-restart-on-upgrade
-
-override_dh_systemd_start:
-       dh_systemd_start -p lxcfs --no-restart-on-upgrade lxcfs.service
+override_dh_installsystemd:
+       install -dm755 $(CURDIR)/debian/lxcfs/lib
+       mv $(CURDIR)/debian/lxcfs/usr/lib/systemd \
+          $(CURDIR)/debian/lxcfs/lib/systemd
+       dh_installsystemd -p lxcfs --no-start --no-stop-on-upgrade lxcfs.service