Downgrade the checking for 'extra qualification' introduced by latest gcc version