bump version for Debian Jessie
authorDietmar Maurer <dietmar@proxmox.com>
Thu, 26 Feb 2015 10:19:59 +0000 (11:19 +0100)
committerDietmar Maurer <dietmar@proxmox.com>
Thu, 26 Feb 2015 10:19:59 +0000 (11:19 +0100)
Makefile
README.dev
debian/changelog

index 0b2ae38..9f25911 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
-RELEASE=3.3
+RELEASE=4.0
 
-VERSION=3.0
-PKGREL=24
+VERSION=4.0
+PKGREL=1
 
 PACKAGE=libpve-common-perl
 
index 5db68b9..0c4abdb 100644 (file)
@@ -1,10 +1,20 @@
 ====================================
-Setup PVE v2 Development Environment
+Setup PVE Development Environment
 ====================================
 
-1.  Install Debian 'wheezy'
+1.  Install Debian 'jessie'
 2.  Install prerequisites for development environment:
 
+# new jessie depends
+apt-get -y install build-essential git-core debhelper autotools-dev \
+doxygen check pkg-config groff quilt dpatch automake autoconf libtool  \
+lintian libdevel-cycle-perl libjson-perl libcommon-sense-perl    \
+liblinux-inotify2-perl libio-stringy-perl libstring-shellquote-perl  \
+dh-systemd rpm2cpio libsqlite3-dev sqlite3 libglib2.0-dev librrd-dev \
+librrds-perl rrdcached libdigest-hmac-perl libxml-parser-perl \
+gdb 
+
+# old wheezy depends
 apt-get -y install build-essential git-core debhelper autotools-dev \
 doxygen check pkg-config libnss3-dev groff quilt dpatch libxml2-dev \
 libncurses5-dev libslang2-dev libldap2-dev xsltproc python-pexpect \
@@ -29,6 +39,7 @@ libio-multiplex-perl liblockfile-simple-perl
 
 You currently need the following packages:
 
+libqb.git
 corosync-pve.git
 openais-pve.git
 pve-common.git
index b252d8e..9019083 100644 (file)
@@ -1,3 +1,9 @@
+libpve-common-perl (4.0-1) unstable; urgency=medium
+
+  * bump version for Debian Jessie
+
+ -- Proxmox Support Team <support@proxmox.com>  Thu, 26 Feb 2015 11:18:57 +0100
+
 libpve-common-perl (3.0-24) unstable; urgency=low
 
   * next_migrate_port: higher port range