]> git.proxmox.com Git - pve-sheepdog.git/blobdiff - debian/rules
build: reformat debian/control
[pve-sheepdog.git] / debian / rules
index a22fc671277eaa57cffe16ebc16aea70f9ee8b94..f8300a839247410ab2d9dd8eecd72582c5275a59 100755 (executable)
@@ -1,21 +1,28 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
 
-# Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
+export DEB_BUILD_HARDENING=1
+
 %:
-       dh --with quilt $@ 
+       dh --with quilt,systemd $@ 
+
+override_dh_auto_install:
+       dh_auto_install
+       rm debian/pve-sheepdog/usr/lib/sheepdog/libsheepdog.a
+       rm debian/pve-sheepdog/usr/lib/sheepdog/libsheepdog.la
+       rm -rf debian/pve-sheepdog/usr/include
+       rm debian/pve-sheepdog/etc/init.d/sheepdog
+       rmdir debian/pve-sheepdog/etc/init.d
+       install -D -m 0755 debian/sheepdog-start-wrapper debian/pve-sheepdog/usr/lib/sheepdog/sheepdog-start-wrapper
 
 override_dh_installinit:
+       # just install install pve-sheepdog.sheepdog.default
        dh_installinit --name sheepdog
 
 override_dh_auto_configure:
        ./autogen.sh
-       dh_auto_configure --enable-zookeeper
+       dh_auto_configure -- --enable-zookeeper --enable-systemd --libdir=/usr/lib/sheepdog
 
+override_dh_systemd_enable:
+       dh_systemd_enable -p pve-sheepdog --name sheepdog sheepdog.service