set Caller-Allowable-Codebase and remove Trusted-Library
authorDietmar Maurer <dietmar@proxmox.com>
Fri, 8 Nov 2013 10:22:08 +0000 (11:22 +0100)
committerDietmar Maurer <dietmar@proxmox.com>
Fri, 8 Nov 2013 10:22:08 +0000 (11:22 +0100)
see http://stackoverflow.com/questions/19393826/java-applet-manifest-allow-all-caller-allowable-codebase

VncViewer.jar
tigerpatches/set-trusted-lib.patch

index e8b113d..0569e04 100644 (file)
Binary files a/VncViewer.jar and b/VncViewer.jar differ
index b7eed34..16da983 100644 (file)
@@ -1,9 +1,11 @@
 Index: new/java/src/com/tigervnc/vncviewer/MANIFEST.MF
 ===================================================================
 --- new.orig/java/src/com/tigervnc/vncviewer/MANIFEST.MF       2011-08-18 14:05:33.000000000 +0200
-+++ new/java/src/com/tigervnc/vncviewer/MANIFEST.MF    2013-11-07 12:11:41.000000000 +0100
-@@ -1,2 +1,4 @@
++++ new/java/src/com/tigervnc/vncviewer/MANIFEST.MF    2013-11-08 11:17:13.000000000 +0100
+@@ -1,2 +1,6 @@
  Manifest-Version: 1.0
  Main-Class: com.tigervnc.vncviewer.VncViewer
-+Trusted-Library: true
 +Permissions: all-permissions
++Application-Name: vncterm
++Codebase: *
++Caller-Allowable-Codebase: *