]> git.proxmox.com Git - zfsonlinux.git/blame - zfs/debian/patches/0007-Fix-ksh-path-for-random_readwrite_fixed.ksh.patch
add 3 patches for lintian errors
[zfsonlinux.git] / zfs / debian / patches / 0007-Fix-ksh-path-for-random_readwrite_fixed.ksh.patch
CommitLineData
9e02600b
SI
1From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
2From: Stoiko Ivanov <s.ivanov@proxmox.com>
3Date: Tue, 21 May 2019 18:19:01 +0200
4Subject: [PATCH] Fix ksh-path for random_readwrite_fixed.ksh
5
6The test in zfs-tests/tests/perf/regression/random_readwrite_fixed.ksh
7is the only file to use /usr/bin/ksh in the shebang.
8Change it to /bin/ksh for consistency.
9
10Signed-off-by: Stoiko Ivanov <s.ivanov@proxmox.com>
11---
12 tests/zfs-tests/tests/perf/regression/random_readwrite_fixed.ksh | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/tests/zfs-tests/tests/perf/regression/random_readwrite_fixed.ksh b/tests/zfs-tests/tests/perf/regression/random_readwrite_fixed.ksh
16index 38c0669f6..e368ed236 100755
17--- a/tests/zfs-tests/tests/perf/regression/random_readwrite_fixed.ksh
18+++ b/tests/zfs-tests/tests/perf/regression/random_readwrite_fixed.ksh
19@@ -1,4 +1,4 @@
20-#!/usr/bin/ksh
21+#!/bin/ksh
22 # file and its contents are supplied under the terms of the
23 # Common Development and Distribution License ("CDDL"), version 1.0.
24 # You may only use this file in accordance with the terms of version