]> git.proxmox.com Git - zfsonlinux.git/blob - spl/debian/rules
55e3568b82adce32ce45222c3b05c369c1598c6e
[zfsonlinux.git] / spl / debian / rules
1 #!/usr/bin/make -f
2
3 include /usr/share/dpkg/pkg-info.mk
4
5 VERSION := $(DEB_VERSION_UPSTREAM)
6 REVISION := $(shell echo $(DEB_VERSION) | cut -d- -f2)
7
8 export DEB_BUILD_MAINT_OPTIONS = hardening=+all
9
10 %:
11 dh $@ --with autoreconf --parallel
12
13 override_dh_auto_configure:
14 @# Embed the downstream version in the module.
15 @sed \
16 -e 's/^Version:.*/Version: $(VERSION)/' \
17 -e 's/^Release:.*/Release: $(REVISION)/' \
18 -i.orig META
19
20 @# Build the userland, but don't build the kernel modules.
21 dh_auto_configure -- --with-config=user --disable-debug-kmem
22
23 override_dh_auto_test:
24 # scripts/check.sh tries insmod and rmmod, so it cannot
25 # run in an unprivileged build environment.
26
27 override_dh_auto_install:
28 @# Install the utilities.
29 $(MAKE) install DESTDIR='$(CURDIR)/debian/tmp'
30
31 override_dh_auto_clean:
32 dh_auto_clean
33 @if test -e META.orig; then mv META.orig META; fi