]> git.proxmox.com Git - zfsonlinux.git/blob - zfs/debian/patches/0006-Use-python3-for-arcstat.py-arc_summary.py-dbufstat.p.patch
rebase patches on top of zfs-0.7.13
[zfsonlinux.git] / zfs / debian / patches / 0006-Use-python3-for-arcstat.py-arc_summary.py-dbufstat.p.patch
1 From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
2 From: Colin Ian King <colin.king@canonical.com>
3 Date: Mon, 17 Oct 2016 14:30:56 +0800
4 Subject: [PATCH] Use python3 for arcstat.py, arc_summary.py & dbufstat.py
5
6 ---
7 cmd/arc_summary/arc_summary.py | 2 +-
8 cmd/arcstat/arcstat.py | 2 +-
9 cmd/dbufstat/dbufstat.py | 2 +-
10 3 files changed, 3 insertions(+), 3 deletions(-)
11
12 diff --git a/cmd/arc_summary/arc_summary.py b/cmd/arc_summary/arc_summary.py
13 index f6dbb9bfb..723c2e5a6 100755
14 --- a/cmd/arc_summary/arc_summary.py
15 +++ b/cmd/arc_summary/arc_summary.py
16 @@ -1,4 +1,4 @@
17 -#!/usr/bin/python
18 +#!/usr/bin/python3
19 #
20 # $Id: arc_summary.pl,v 388:e27800740aa2 2011-07-08 02:53:29Z jhell $
21 #
22 diff --git a/cmd/arcstat/arcstat.py b/cmd/arcstat/arcstat.py
23 index d7d3e9b73..3a7a47d67 100755
24 --- a/cmd/arcstat/arcstat.py
25 +++ b/cmd/arcstat/arcstat.py
26 @@ -1,4 +1,4 @@
27 -#!/usr/bin/python
28 +#!/usr/bin/python3
29 #
30 # Print out ZFS ARC Statistics exported via kstat(1)
31 # For a definition of fields, or usage, use arctstat.pl -v
32 diff --git a/cmd/dbufstat/dbufstat.py b/cmd/dbufstat/dbufstat.py
33 index 42bb0c7c7..73e02ca11 100755
34 --- a/cmd/dbufstat/dbufstat.py
35 +++ b/cmd/dbufstat/dbufstat.py
36 @@ -1,4 +1,4 @@
37 -#!/usr/bin/python
38 +#!/usr/bin/python3
39 #
40 # Print out statistics for all cached dmu buffers. This information
41 # is available through the dbufs kstat and may be post-processed as