]> git.proxmox.com Git - zfsonlinux.git/blob - zfs/debian/patches/0008-test-runner.py-change-shebang-to-python3.patch
add 3 patches for lintian errors
[zfsonlinux.git] / zfs / debian / patches / 0008-test-runner.py-change-shebang-to-python3.patch
1 From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
2 From: Stoiko Ivanov <s.ivanov@proxmox.com>
3 Date: Thu, 23 May 2019 15:22:27 +0200
4 Subject: [PATCH] test-runner.py: change shebang to python3
5
6 In commit 6e72a5b9b61066146deafda39ab8158c559f5f15 python scripts which
7 work with python2 and python3 changed the shebang from /usr/bin/python
8 to /usr/bin/python3. This gets adapted by the build-system on systems
9 which don't provide python3.
10 This commit changes test-runner.py to also use /usr/bin/python3,
11 enabling the change during buildtime and fixing a minor lintian issue
12 on Debian systems, which only have python3 installed.
13
14 Signed-off-by: Stoiko Ivanov <s.ivanov@proxmox.com>
15 ---
16 tests/test-runner/bin/test-runner.py | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19 diff --git a/tests/test-runner/bin/test-runner.py b/tests/test-runner/bin/test-runner.py
20 index ea37e8ab6..4d4fd96ad 100755
21 --- a/tests/test-runner/bin/test-runner.py
22 +++ b/tests/test-runner/bin/test-runner.py
23 @@ -1,4 +1,4 @@
24 -#!/usr/bin/python
25 +#!/usr/bin/python3
26
27 #
28 # This file and its contents are supplied under the terms of the