]> git.proxmox.com Git - ceph.git/blame - ceph/debian/ceph-osd.postinst
bump version to 18.2.2-pve1
[ceph.git] / ceph / debian / ceph-osd.postinst
CommitLineData
aee94f69 1#!/bin/sh
7c673cae
FG
2# vim: set noet ts=8:
3# postinst script for ceph-osd
4#
5# see: dh_installdeb(1)
6
7set -e
8
9# summary of how this script can be called:
10#
11# postinst configure <most-recently-configured-version>
12# old-postinst abort-upgrade <new-version>
13# conflictor's-postinst abort-remove in-favour <package> <new-version>
14# postinst abort-remove
15# deconfigured's-postinst abort-deconfigure in-favour <failed-install-package> <version> [<removing conflicting-package> <version>]
16#
17
18# for details, see http://www.debian.org/doc/debian-policy/ or
19# the debian-policy package
20
21[ -f "/etc/default/ceph" ] && . /etc/default/ceph
22[ -z "$SERVER_USER" ] && SERVER_USER=ceph
23[ -z "$SERVER_GROUP" ] && SERVER_GROUP=ceph
24
25case "$1" in
26 configure)
3efd9988 27 [ -x /etc/init.d/procps ] && invoke-rc.d procps restart || :
7c673cae
FG
28 [ -x /sbin/start ] && start ceph-osd-all || :
29 ;;
30 abort-upgrade|abort-remove|abort-deconfigure)
31 :
32 ;;
33
34 *)
35 echo "postinst called with unknown argument \`$1'" >&2
36 exit 1
37 ;;
38esac
39
40# dh_installdeb will replace this with shell code automatically
41# generated by other debhelper scripts.
42
43#DEBHELPER#
44
45exit 0
46
47