]> git.proxmox.com Git - ceph.git/blob - ceph/debian/ceph-osd.postinst
update sources to 12.2.7
[ceph.git] / ceph / debian / ceph-osd.postinst
1 # vim: set noet ts=8:
2 # postinst script for ceph-osd
3 #
4 # see: dh_installdeb(1)
5
6 set -e
7
8 # summary of how this script can be called:
9 #
10 # postinst configure <most-recently-configured-version>
11 # old-postinst abort-upgrade <new-version>
12 # conflictor's-postinst abort-remove in-favour <package> <new-version>
13 # postinst abort-remove
14 # deconfigured's-postinst abort-deconfigure in-favour <failed-install-package> <version> [<removing conflicting-package> <version>]
15 #
16
17 # for details, see http://www.debian.org/doc/debian-policy/ or
18 # the debian-policy package
19
20 [ -f "/etc/default/ceph" ] && . /etc/default/ceph
21 [ -z "$SERVER_USER" ] && SERVER_USER=ceph
22 [ -z "$SERVER_GROUP" ] && SERVER_GROUP=ceph
23
24 case "$1" in
25 configure)
26 [ -x /etc/init.d/procps ] && invoke-rc.d procps restart || :
27 [ -x /sbin/start ] && start ceph-osd-all || :
28 # work around https://tracker.ceph.com/issues/24903
29 chown -h ceph:ceph /var/lib/ceph/osd/*/block* 2>&1 > /dev/null || :
30 ;;
31 abort-upgrade|abort-remove|abort-deconfigure)
32 :
33 ;;
34
35 *)
36 echo "postinst called with unknown argument \`$1'" >&2
37 exit 1
38 ;;
39 esac
40
41 # dh_installdeb will replace this with shell code automatically
42 # generated by other debhelper scripts.
43
44 #DEBHELPER#
45
46 exit 0
47
48