]> git.proxmox.com Git - iproute2.git/blobdiff - debian/rules
fix #1637: merge: police: don't skip parameters after actions
[iproute2.git] / debian / rules
index 4215d0a4da8ee78d9c90ec5b553457f72a276863..2f1a1ffe7770db6a449a616497aaaeca10751e22 100755 (executable)
@@ -12,16 +12,13 @@ else
 endif
 
 %:
-       dh $@ --with=quilt
+       dh $@
 
 override_dh_clean:
        dh_clean
        make distclean
        -rm -f doc/*.txt
 
-override_dh_installexamples:
-       dh_installexamples -p iproute2-doc examples/*
-
 override_dh_shlibdeps:
        dh_shlibdeps -a -Xq_atm.so -Xm_xt.so -Xm_ipt.so
        dh_shlibdeps -a -- -pipmods -dRecommends -e debian/iproute2/usr/lib/tc/m_xt.so -e debian/iproute2/usr/lib/tc/q_atm.so -xlibc6
@@ -30,12 +27,5 @@ override_dh_auto_configure:
        $(CROSS) dh_auto_configure
 
 override_dh_auto_build:
-#      $(MAKE) -C doc all txt
-       $(MAKE) -C doc all
+       $(MAKE) -C doc all txt
        $(MAKE) KERNEL_INCLUDE=./include $(CROSS)
-
-# bump version of the transitional packages...
-override_dh_gencontrol:
-       dh_gencontrol -piproute -- -v1:$(DEB_VERSION)
-       dh_gencontrol -piproute-doc -- -v1:$(DEB_VERSION)
-       dh_gencontrol --remaining-packages