update to use the late modules path.