set correct version in control