use new PVE::Tools::encrypt_pw, bump version to 5.0-3